 <B>Generalbass aussetzen</B>

Generalbass aussetzen (Version 7.4)

Dieses Skript legt direkt über der bezifferten Generalbasszeile (linke Hand) eine zusätzliche Notenzeile mit Violinschlüssel (für die rechte Hand) an, in der alle weiteren Noten der jeweiligen Akkorde in der eingestrichenen Oktave ausgesetzt sind - nach F.E. Niedt (1721): "Mit der rechten Hand bleibt man gerne in der Octaven 2-Fuß..." .

Die bezifferte Generalbasszeile kann eine beliebige selektierte Notenzeile sein, i.d.R. ist es aber die letzte Zeile in den Systemen. Deshalb wird im Gb-Einstellungsdialog die letzte Notenzeile der Systeme voreingestellt. Falls die bezifferte Gb-Zeile nicht die letzte Notenzeile sein sollte, müssen in Ausnahmefällen die in der Partitur schon vorhandenen Akkoladenklammern nach dem Aussetzen des Generalbasses im capella-Mustersystem noch angepasst werden.

Die Bezifferung der Generalbasszeile muss für dieses Skript generell mittels Liedtext erfolgt sein. Eine Ausnahme machen nur die reinen Alterationen der Terz; diese können auch mittels Musiksymbol an der jeweiligen Note verankert werden. Hierbei ist darauf zu achten, dass die Note, an der das Alterationszeichen verankert ist, keine weitere Verankerung aufweist!

Für das "Hochalterieren" von Noten dürfen im Liedtext ausschließlich # oder + verwendet werden, also nicht das "Durchstreichen" der Ziffer.

Da das Auflösungszeichen im Liedtext nicht zur Verfügung steht, wird dafür das $-Zeichen verwendet.

Basstöne ohne Bezifferung werden - wie vom Gb vorgesehen - als Akkorde in "Grundstellung" harmonisiert, also mit Grundton im Bass.

Nicht zu harmonisierende Bassnoten, ausgenommen Durchgangs- und Wechselnoten (siehe unten), werden - wie vom Gb vorgesehen - mit 't.s.' (tasto solo) oder einer '0' (Null) versehen.

Bitte passen Sie nach dem Aussetzen des Generalbasses ggf. noch die Bindebögen an:
"Format - Transponieren - Cursorzeile in allen Systemen - Bindebögen - Anpassen ohne Transposition". Dabei muss der Cursor in der neuen Notenzeile (rechte Hand) stehen.

Anmerkungen:

- Beim Aussetzen der Sextakkorde wird der Basston i.d.R. nicht verdoppelt, da diese Akkorde der ersten Umkehrung entsprechen und bei der Verdopplung des Basstones eine "verbotene" Terzverdopplung vorläge. Der eigentliche Grundton des Akkords und die Quinte werden nicht verdoppelt, um Oktav-"Spreizung" für die rechte Hand zu vermeiden, sodass bei dieser Akkord-Art nur zwei Töne für die rechte Hand gesetzt werden. Terzverdopplungen können auf Wunsch (Dialog-Angabe) dennoch vorgenommen werden.

- Als größtes Intervall wird die None (Ziffer 9) unterstützt, wobei zur None auch die Septe aber nicht die Quinte gesetzt wird. Allerdings wird bei einem 9-8-Vorhalt - für eine bessere Stimmführung - zur None nicht die Septe, sondern die Quinte gesetzt.

- Es werden maximal drei "Ebenen"*1 der Bezifferung unterstützt.

*1 "Ebenen" entsprechen den Liedstrophen-"Ebenen"

- Bei Vorhaltsnotierungen*2 an nichtpunktierten Noten werden die Gb-Notenwerte für alle Noten der rechten Hand halbiert und dann entsprechend ausgesetzt.

- Bei Vorhaltsnotierungen*2 an punktierten Noten wird für den Punkt der entsprechende Notenwert für alle Noten der rechten Hand generiert und dann ausgesetzt.

*2 Vorhalte mittels Liedtext werden gesetzt, indem man die beiden Zeichen (z.B. Ziffern) direkt hintereinander schreibt und anschließend mindestens einen Leerschritt zwischen die beiden Zeichen einfügt.

- Harmonisierungen von 1/8-, 1/16-, und 1/32-"Durchgangs- und Wechselnoten" des Basses können im "Prolog" des Skripts wahlweise ein- oder ausgeschaltet werden. Alle größeren Notenwerte werden in jedem Fall harmonisiert. Der Wert des vorausgehenden Akkords der rechten Hand wird um den Wert des nachfolgenden unterdrückten Akkords vergrößert - diese Funktion kann aber abgewählt werden. Punktierte Bassnoten und ihre Ergänzungen und bezifferte Bassnoten werden auf jeden Fall harmonisiert. Durchgangs- und Wechselnoten werden von D bis d' - jeweils einschließlich - erkannt und müssen den gleichen Notenwert haben wie die vorausgehende Note.

- "Erinnerungsvorzeichen" (courtesy accidentals) - wie (#), (b) oder (+) - bleiben bei der Harmonisierung unberücksichtigt.

- Strenge Stimmführungsregeln, wie das Vermeiden von Quint- oder Oktavparallelen, korrekte Führung von Leittönen, Gegenbewegungen zwischen höchsten und tiefsten Tönen der Akkorde usw., können auch in zukünftigen Versionen dieses Skripts nicht garantiert werden.

- Die beiden Generalbasszeilen werden mit einer geschweiften Klammer versehen und im capella-Mustersystem mit "Gb ausgesetzt" und "Generalbass" bezeichnet.

- Eine eventuell vorhandene Gb-Instrumentenbezeichnung wird automatisch zwischen beide Gb-Zeilen platziert.

- Die Laufzeit dieses Python-Skripts kann bei größeren Partituren - besonders beim ersten Aufruf - recht lang sein. Bitte haben Sie ein wenig Geduld!

- Auf meiner Internetseite [www.HanshLampe.de] steht unter capella-Skripte ein Generalbass-Testprogramm zur Verfügung.

Autor dieses Skripts: Hans H. Lampe

Rückmeldungen per eMail bitte an: HansHermann.Lampe@t-online.de